iFIBER - iFIBER Incident North Grant County – Incident details

All systems operational

iFIBER Incident North Grant County

Resolved
Partial outage
Started about 2 months agoLasted 1 day

Affected

PUD Fiber

Partial outage from 6:03 PM to 9:39 PM, Operational from 6:03 PM to 7:05 PM, Partial outage from 9:39 PM to 7:05 PM

Grant County Fiber

Partial outage from 6:03 PM to 7:05 PM

Chelan County Fiber

Operational from 6:03 PM to 7:05 PM

Douglas County Fiber

Operational from 6:03 PM to 7:05 PM

PO County Fiber

Operational from 6:03 PM to 7:05 PM

Mason County Fiber

Operational from 6:03 PM to 7:05 PM

Updates
  • Resolved
    Resolved

    Good news - iFIBER customers in your area are up and running after today's outage. Thanks for your patience!

  • Identified
    Identified

    Fiber service remains out to customers north of Soap Lake after a tree-trimming crew accidentally cut a fiber-optic cable. Repair is underway but time consuming. Service will likely be out until 8 p.m.

  • Investigating
    Investigating

    Customers in your area may be experiencing service issues. We’re urgently working on a fix & will update you when service is restored.

    Fiber issue effecting Coulee City, Grand Coulee, and Electric City.