iFIBER - iFIBER Incident – Incident details

All systems operational

iFIBER Incident

Resolved
Operational
Started 7 days agoLasted about 9 hours

Affected

Kitsap County Fiber

Partial outage from 12:05 AM to 9:05 AM

Updates
  • Resolved
    Resolved

    Good news - iFIBER customers in your area are up and running after today's outage. Thanks for your patience!

  • Investigating
    Investigating

    Customers in your area may be experiencing service issues. We’re urgently working on a fix & will update you when service is restored.

    We have a fiber break impacting a large number of customer in the Bremerton and Silverdale area.  Crews have been dispatched.