iFIBER - iFIBER Incident – Incident details

All systems operational

iFIBER Incident

Resolved
Partial outage
Started 3 months agoLasted about 3 hours

Affected

Grant County Fiber

Partial outage from 1:45 AM to 4:42 AM

Wireless

Partial outage from 1:45 AM to 4:42 AM

Updates
  • Resolved
    Resolved

    Good news - iFIBER customers in your area are up and running after today's outage. Thanks for your patience!

  • Investigating
    Investigating

    Customers in your area may be experiencing service issues. We’re urgently working on a fix & will update you when service is restored.

    Power outage in Royal City/Othello area. ETA 1hr