iFIBER - iFIBER Incident – Incident details

All systems operational

iFIBER Incident

Resolved
Partial outage
Started 3 months agoLasted about 2 hours

Affected

Grant County Fiber

Partial outage from 8:18 PM to 10:16 PM

Chelan County Fiber

Partial outage from 8:18 PM to 10:16 PM

Douglas County Fiber

Partial outage from 8:18 PM to 10:16 PM

PO County Fiber

Partial outage from 8:18 PM to 10:16 PM

Mason County Fiber

Partial outage from 8:18 PM to 10:16 PM

Kitsap County Fiber

Partial outage from 8:18 PM to 10:16 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating

    Customers in your area may be experiencing service issues. We’re urgently working on a fix & will update you when service is restored.