iFIBER - iFIBER Incident – Incident details

All systems operational

iFIBER Incident

Resolved
Partial outage
Started 3 months agoLasted 15 minutes

Affected

Grant County Fiber

Partial outage from 3:59 PM to 4:15 PM

Updates
  • Resolved
    Resolved

    Good news - iFIBER customers in your area are up and running after today's outage. Thanks for your patience!

  • Identified
    Identified

    Customers in your area may be experiencing service issues. We’re urgently working on a fix & will update you when service is restored.

    From Grant PUD:
    We're working to restore power to about 1,000 customers in the Larson area of Moses Lake. We expect power to be restored by 11 a.m. this morning. We'll provide updates when we have more information to share.