iFIBER - iFIBER Incident – Incident details

All systems operational

iFIBER Incident

Resolved
Partial outage
Started 3 months agoLasted about 2 hours

Affected

Kitsap County Fiber

Partial outage from 10:45 PM to 12:24 AM

Updates
  • Resolved
    Resolved

    Good news - iFIBER customers in your area are up and running after today's outage. Thanks for your patience!

  • Identified
    Identified

    Customers in your area may be experiencing service issues. We’re urgently working on a fix & will update you when service is restored.