iFIBER - iFIBER Incident – Incident details

All systems operational

iFIBER Incident

Resolved
Partial outage
Started 3 months agoLasted about 5 hours

Affected

PO County Fiber

Partial outage from 8:21 PM to 1:00 AM

Kitsap County Fiber

Partial outage from 8:21 PM to 9:47 PM, Operational from 9:47 PM to 1:00 AM

Updates
  • Resolved
    Resolved

    Good news - iFIBER customers in your area are up and running after today's outage. Thanks for your patience!

  • Identified
    Identified

    Service in Kitsap should be restored. Still down in Pend Oreille County.

  • Investigating
    Investigating

    Customers in your area may be experiencing service issues. We’re urgently working on a fix & will update you when service is restored.