iFIBER - iFIBER Incident – Incident details

All systems operational

iFIBER Incident

Resolved
Major outage
Started 4 months agoLasted about 2 hours

Affected

Grant County Fiber

Partial outage from 3:39 PM to 3:59 PM, Major outage from 3:59 PM to 5:50 PM

Chelan County Fiber

Partial outage from 3:39 PM to 3:59 PM, Major outage from 3:59 PM to 5:50 PM

Douglas County Fiber

Partial outage from 3:39 PM to 3:59 PM, Major outage from 3:59 PM to 5:50 PM

PO County Fiber

Partial outage from 3:39 PM to 3:59 PM, Major outage from 3:59 PM to 5:50 PM

Mason County Fiber

Partial outage from 3:39 PM to 3:59 PM, Major outage from 3:59 PM to 5:50 PM

Kitsap County Fiber

Partial outage from 3:39 PM to 3:59 PM, Major outage from 3:59 PM to 5:50 PM

Updates
  • Resolved
    Resolved

    Good news - iFIBER customers in your area are up and running after today's outage. Thanks for your patience!

  • Identified
    Update

    We are working on replacing some faulty hardware. We estimate approx. 1.5 to 2 hours for a time to resolution, although it is is just an estimate.

    We will post additional updates as we get new information. Thank you for your patience.

  • Identified
    Identified

    We have identified the source of the outage and have technicians en route to implement a fix.

  • Investigating
    Investigating

    Customers in your area may be experiencing service issues. We’re urgently working on a fix & will update you when service is restored.