All systems operational

iFIBER Incident

Resolved
Partial outage
Started about 2 months ago Lasted less than a minute

Affected

Grant County Fiber
Updates
  • Resolved
    Resolved

    Good news - iFIBER customers in your area are up and running after today's outage.

    There was an equipment issue affecting some customers’ ability to obtain IP addresses. That has been resolved. If you are still unable to connect, reboot your router. If that doesn’t work, please call and speak to our support staff, and we’ll get you taken care of.

    Thanks for your patience!

  • Investigating
    Update

    There are more areas of Grant County affected. Our team is working with Grant County PUD.

  • Investigating
    Investigating

    Customers in areas of Mattawa and Moses Lake may be experiencing service issues. We’re urgently working on a fix & will update you when service is restored.