All systems operational

iFIBER Incident

Resolved
Operational
Started 2 months ago Lasted about 10 hours

Affected

Grant County Fiber
Updates
  • Resolved
    Resolved

    Great news - iFIBER customers in your area are up and running after today's outage. Thank you for your patience!

  • Identified
    Update

    While service has been restored to most, Grant PUD is still working on restoring service to a portion of the fiber network. We continue to work with them on the issue.

  • Identified
    Update

    Grant PUD has restored connectivity to most of the county and are working on restoring connectivity to those who are still affected.

  • Identified
    Identified

    Connectivity has been restored to some areas of the county. Grant PUD is working to restore connectivity to areas that are still affected.

  • Investigating
    Update

    There is a connectivity issue affecting all service providers in Grant PUD’s fiber network. We are working with Grant PUD on the issue.

  • Investigating
    Investigating

    Customers in your area may be experiencing service issues. We’re urgently working on a fix & will update you when service is restored.