All systems operational

iFIBER Incident 2024-03-09

Resolved
Operational
Started 2 months ago Lasted 2 days

Affected

Grant County Fiber
Updates
  • Resolved
    Resolved

    Good news - iFIBER customers in your area are up and running after today's outage. Thanks for your patience!

  • Monitoring
    Monitoring

    We have identified the problem and have implemented a fix that appears to have solved the problem. We are closely monitoring things before we mark the issue resolved.

    Please call us and speak with our technical support representatives if you are still having connectivity troubles. (509) 754-2600

  • Investigating
    Update

    Our team was made aware of an outage on Saturday 3/9/2024. Our team has been diligently working on resolving the issue since then. We have not yet identified the direct cause, but we know that it is only affecting some subscribers on Grant PUD's fiber network.

    If your internet is affected, please call us at (509) 754-2600 to speak with a technical support representative and we will help get you back online.

  • Investigating
    Update

    We have technicians on-site and are working with Grant PUD on the issue.

  • Investigating
    Investigating

    Some customers may still be unable to connect. We're investigating again.

  • Monitoring
    Monitoring

    We worked with Grant Fiber and implemented a fix.

  • Investigating
    Investigating

    Some customers in your area may be experiencing service issues. We’re urgently working on a fix & will update you when service is restored.