All systems operational

iFIBER Incident

Resolved
Partial outage
Started 5 months ago Lasted about 18 hours

Affected

Wireless
Updates
  • Investigating
    Investigating

    Customers in your area may be experiencing service issues. We’re urgently working on a fix & will update you when service is restored.

  • Resolved
    Resolved

    Good news - iFIBER customers in your area are up and running after today's outage. Thanks for your patience!