All systems operational

Stemilt Tower Near Mattawa

Resolved
Operational
Started 7 months ago Lasted about 21 hours

Affected

Wireless
Updates
  • Resolved
    Resolved

    This incident has been resolved.

  • Identified
    Identified

    The tower has no power. We are in route to repair.

    Unable to gain access. Will be back out onsite in the AM.