Scheduled for August 07, 2025 at 12:00 PM – 3:00 PM
Affects
PUD Fiber
Under maintenance from 12:00 PM to 3:00 PM
Mason County Fiber
Under maintenance from 12:00 PM to 3:00 PM
Updates
Completed
August 07, 2025 at 3:00 PM
Completed
August 07, 2025 at 3:00 PM
Maintenance has completed successfully
In progress
August 07, 2025 at 12:00 PM
In progress
August 07, 2025 at 12:00 PM
Maintenance is now in progress
Planned
August 07, 2025 at 12:00 PM
Planned
August 07, 2025 at 12:00 PM
Mason PUD3 will be performing maintenance that will be potentially service affecting to the following locations. Work is scheduled to start at 5am and end at 8am.